Warning: Can't synchronize with repository "(default)" (No changeset 96d22ec3fa3ef6de3ea8dc0d7d398adc9aa071cf in the repository). Look in the Trac log for more information.

Ticket #439 (closed defect: wontfix)

Opened 5 years ago

Last modified 3 years ago

ogsmd.channel ERROR (ignoring) unhandled exception in response callback: 0

Reported by: KaZeR Owned by: daniel
Priority: major Milestone:
Component: framework/ogsmd/sms Version: milestone5
Keywords: shr unstable messages sms crash Cc: kazer@…

Description

Hi,

Since a few days, i'm facing the following issue when trying to access my messagebook, via shr-unstable's openmoko-messages or via dbus call :

2009.05.20 15:22:11.85 ogsmd.channel        ERROR    (ignoring) unhandled exception in response callback: 0
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/framework/subsystems/ogsmd/gsm/channel.py", line 430, in handleResponseToRequest
    ok_cb( reqstring.strip(), response )
  File "/usr/lib/python2.6/site-packages/framework/subsystems/ogsmd/modems/abstract/mediator.py", line 1035, in responseFromChannel
    result.append( ( index, status, str(sms.addr), sms.ud, sms.properties ) )
  File "/usr/lib/python2.6/site-packages/framework/subsystems/ogsmd/gsm/sms.py", line 471, in _getProperties
    map.update( self._get_udh() )
  File "/usr/lib/python2.6/site-packages/framework/subsystems/ogsmd/gsm/sms.py", line 326, in _get_udh
    map["csm_id"] = self.udh[0][0]*256 + self.udh[0][1]
KeyError: 0

I'm starting to believe that it may be related to a pdu message.

I was running unstable from 20090509 without upgrades. It broke after a few days. I upgraded to latest, it didn't solve the issue. I flashed back to 20090509 (which worked for a few days) and the issue was still there. I have a few messages (which i can "view" using mickeyterm and at commands) which may be the cause of the issue, but i can't "read" them since they are encoded.

Let me know if more details are needed.

Thanks in advance.

Attachments

frameworkd.log (31.2 KB) - added by KaZeR 5 years ago.
frameworkd.log for ticket #439

Change History

comment:1 Changed 5 years ago by dos

  • Status changed from new to closed
  • Resolution set to fixed

opkg update; opkg upgrade

It's fixed (by alphaone) for some time.

Changed 5 years ago by KaZeR

frameworkd.log for ticket #439

comment:2 Changed 5 years ago by KaZeR

  • Cc kazer@… added
  • Status changed from closed to reopened
  • Resolution fixed deleted

I did the upgrade.

I still can't access my messages. openmoko-messages segfaults right when starting up

** (process:1603): DEBUG: Trying to get the system bus
** (process:1603): DEBUG: Adding signals.
** (process:1603): DEBUG: Entering ecore loop
** (process:1603): DEBUG: phonegui_messages_show()
** (process:1603): DEBUG: ogsmd_sim_retrieve_phonebook_callback()
** (process:1603): DEBUG: cache_phonebook_callback called
** (process:1603): DEBUG: caching phonebook failed: The name org.freesmartphone.ogsmd was not provided by any .service files dbus -1
** (process:1603): DEBUG: Initiated elementary
** (process:1603): DEBUG: Initiated etk
** (process:1603): DEBUG: event_callback()
** (process:1603): DEBUG: _show()
** (process:1603): DEBUG: window_init(win=76320)
** (process:1603): DEBUG: window_view_show()
** (process:1603): DEBUG: window_view_hide()
** (process:1603): DEBUG: message_list_view_show()
** (process:1603): DEBUG: tree init
** (process:1603): DEBUG: ogsmd_sim_retrieve_messagebook_callback()
** (process:1603): DEBUG: retrieve messagebook callback(error=273424)
Segmentation fault

Nothing in frameworkd.log now. The phone registers to the network correctly, but no calls, sms or gprs is possible.

Attached is my frameworkd.log. Let me know if i should open a new ticket.

comment:3 Changed 4 years ago by sim

decoration Changed 1 year ago by admin

bathtub Changed 1 year ago by admin

solar system Changed 1 year ago by admin

stair parts Changed 1 year ago by admin

solar supply Changed 1 year ago by admin

comment:4 Changed 3 years ago by mickey

  • Status changed from reopened to closed
  • Resolution set to wontfix

ogsmd is being outphased. fsogsmd has completely rewritten SMS handling. Please open another bug, if you have the same problem with fsogsmd. Thanks for reporting!

Note: See TracTickets for help on using tickets.