Warning: Can't synchronize with repository "(default)" (No changeset 96d22ec3fa3ef6de3ea8dc0d7d398adc9aa071cf in the repository). Look in the Trac log for more information.

Ticket #389 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

otimed sets timezone incorrectly in large countries

Reported by: mmontour Owned by: jluebbe
Priority: major Milestone:
Component: framework/otimed Version:
Keywords: localtime zoneinfo Cc:

Description

otimed is currently obtaining an ISO country code from GSM and then setting the timezone (/etc/localtime) by looking up the country code in /usr/share/zoneinfo/zone.tab and taking the first matching row. This does not work correctly in countries like Canada that span more than one timezone. My Freerunner insists that it is in Newfoundland although it is actually on the other side of the continent in Vancouver.

A secondary note - I originally had /etc/localtime as a symlink to /usr/share/zoneinfo/Canada/Pacific. When otimed did its update, this clobbered the Canada/Pacific? file with the America/St_Johns one. I'm willing to accept a resolution of "well, don't use a symlink there" but I thought it was worth mentioning this.

The package version on my phone is "frameworkd - 0.8.5.1+gitr5+e68f539c4b2e5a22da3f5c30d0b2591b81960718-r0". This was built locally with OE, not from a standard distro, but I have checked that this code fragment in _handleNetworkInfoReply() is the same in the current git.freesmartphone.org tree.

See also: https://docs.openmoko.org/trac/ticket/2244

Change History

comment:1 Changed 5 years ago by jluebbe

  • Status changed from new to accepted

comment:2 Changed 5 years ago by daniel

Jan, any comment? Could we just not change the timezone if the current one already belongs to that country?

comment:3 Changed 5 years ago by daniel

  • Status changed from accepted to closed
  • Resolution set to duplicate

Duplicate of #337

Note: See TracTickets for help on using tickets.