Warning: Can't synchronize with repository "(default)" (No changeset 96d22ec3fa3ef6de3ea8dc0d7d398adc9aa071cf in the repository). Look in the Trac log for more information.

Ticket #342 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

SetResourcePolicy weirdness

Reported by: spaetz Owned by: jluebbe
Priority: major Milestone:
Component: framework/oeventsd Version:
Keywords: Cc:

Description

I set WiFi? to enabled, Display to auto:

mdbus  -s org.freesmartphone.ousaged /org/freesmartphone/Usag
e org.freesmartphone.Usage.GetResourcePolicy Display 
'auto'
....GetResourcePolicy WiFi   
'enabled'

Leads to:

  ... org.freesmartphone.Usage.GetResourceState WiFi
  True
  ....GetResourceState Display
  False

Strangely, Suddenly the idle_dim signal will not occur anymore. Actually frameworkd.log (debug) will not show any busy, idle, or idle_dim events, signals, or methods.

Setting now ResourcePolicy? for WiFi? to "auto" again will immediately turn off WiFi?, however idle events/signals/methods will still not occur, the screen stays bright, whereas it had worked/dimmed before I twiddled with WiFi? ResoucePolicy?.

Change History

comment:1 Changed 5 years ago by spaetz

I am very sorry that I have to be so unprecise, and I know I am being not very helpful, but there is something else going on besides the described above. I don't even get the idle events anymore when I turned the WiFi? off and didn't touch any ResourcePolicy? settings.

I am very confused, if you feel that this bug should be closed please do so. I have to admit that debugging this is very difficult for me.

Can it be that the idle events are suppres as soon as frameworkd receives a working "netlink" connection or something? I guess only the code can answer that...

comment:2 Changed 5 years ago by jluebbe

  • Status changed from new to closed
  • Resolution set to duplicate

I think this has nothing to WiFi? and is just a duplicate of #336. If you can reproduce this, please reopen.

Note: See TracTickets for help on using tickets.