Opened 5 years ago

Closed 5 years ago

#330 closed defect (fixed)

RealTimeClock.SetCurrentTime isn't working

Reported by: dos Owned by: mickey
Priority: major Milestone: milestone5
Component: framework/odeviced Version:
Keywords: odeviced rtc setcurrenttime Cc: seba.dos1@…

Description

org.freesmartphone.odeviced /org/freesmartphone/Device/RealTimeClock/rtc0 org.freesmartphone.Device.RealTimeClock?.SetCurrentTime?

DBusException: org.freedesktop.DBus.Python.NameError?: Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/dbus/service.py", line 702, in _message_cb

retval = candidate_method(self, *args, keywords)

File "/usr/lib/python2.6/site-packages/framework/subsystems/odeviced/kernel26.py", line 431, in SetCurrentTime?

pyrtc.rtcSetTime( time.gmtime( t ) )

NameError?: global name 'pyrtc' is not defined

Change History (5)

comment:1 follow-up: Changed 5 years ago by jluebbe

comment:2 in reply to: ↑ 1 Changed 5 years ago by dos

Replying to jluebbe:

You probably don't have pyrtc installed:

http://git.freesmartphone.org/?p=python-helpers.git;a=tree;f=pyrtc;h=c002b3b156074aee3edb51aeacbc5d3473fdfb05;hb=HEAD

Are you using the fso-images?

I'm using SHR, but python-pyrtc is installed. The problem is "import pyrtc" line is missing in /usr/lib/python2.6/site-packages/framework/subsystems/odeviced/kernel26.py file. When I added it manually some time ago, I had another python error.

comment:3 Changed 5 years ago by jluebbe

  • Milestone set to milestone5
  • Owner changed from mickey to jluebbe
  • Status changed from new to accepted

Ok, the problem is that pyrtc is not imported in that function.

comment:4 Changed 5 years ago by mickey

  • Owner changed from jluebbe to mickey
  • Status changed from accepted to assigned

comment:5 Changed 5 years ago by mickey

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.