Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#265 closed defect (fixed)

gps resets to NMEA mode on milestone 4.1

Reported by: ant@… Owned by: daniel
Priority: major Milestone: milestone5.5
Component: framework/ogpsd Version: milestone4
Keywords: ubx nmea gps Cc: ant@…

Description

See:
http://lists.openmoko.org/nabble.html#nabble-tt1521077%7Ca1578627

Shortly after turning the GPS on and updating the almanac data (sing UBX mode) , the syslog shows the GPS issuing a bunch of messages in NMEA mode declaring GPS manufacturer, version etc, then lots of lines like:

Nov 24 14:44:49 om-gta02 user.debug 2008.11.24 14:44:49 ogpsd DEBUG
Discarded data not UBX '06 12:00:00*76\r\n'

then this exception message:

Nov 24 14:44:49 om-gta02 user.debug 2008.11.24 14:44:49 ogpsd DEBUG
Discarded data not UBX ',Excepti'
Nov 24 14:44:49 om-gta02 user.debug 2008.11.24 14:44:49 ogpsd DEBUG
Discarded data not UBX 'on 0x800'
Nov 24 14:44:49 om-gta02 user.debug 2008.11.24 14:44:49 ogpsd DEBUG
Discarded data not UBX '00040 was trappe'
Nov 24 14:44:49 om-gta02 user.debug 2008.11.24 14:44:49 ogpsd DEBUG
Discarded data not UBX 'd !*7E\r\n'

The discarded data suggests that the GPS is getting a fix, but because all the data is being discarded no GPS applications can read the data.

Attachments (2)

gpslog_start (137.5 KB) - added by ajohnson 6 years ago.
ogpsd debug log from SHR
gps-ubx-errors.txt (38.5 KB) - added by ant@… 6 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 6 years ago by daniel

If you could attach the complete log regarding GPS to this ticket that would be great.

Changed 6 years ago by ajohnson

ogpsd debug log from SHR

comment:2 Changed 6 years ago by ajohnson

Attached log from SHR shows the symptoms described here. I've truncated the log shortly after the NMEA messages show a GPS fix. I forgot to dump package versions when I took the log, and may have updated since. Sorry.

Changed 6 years ago by ant@…

comment:3 Changed 6 years ago by ant@…

  • Cc ant@… added

My milestone 4 install has started failing in the same way - see gps-ubx-errors.txt attached. This install was done from the milestone 4 tarball onto the original SD card, and has had almost no changes - setting the oframeworkd.conf log flag to 'DEBUG', changing the root password, and the installation of tangoGPS from the default repository.

A quick 'find' of files that have been updated since the last time it was working:

# find . -mtime -5 | grep -v Maps | grep -v /dev/ | grep -v /sys/ | grep -v /proc/| grep -v volatile

.
./media
./home/root
./home/root/.dbus/session-bus/ef6f6e6cecbbb75de1c0f65d4930031d-0
./home/root/.gconf
./home/root/.gconf/apps/tangogps
./home/root/.gconf/apps/tangogps/%gconf.xml
./home/root/.e/e/config
./home/root/.e/e/config/illume
./home/root/.e/e/config/illume/module.dropshadow.cfg
./home/root/.e/e/config/illume/module.illume.cfg
./home/root/.e/e/config/illume/module.battery.cfg
./home/root/.e/e/config/illume/module.pager.cfg
./home/root/.e/e/config/illume/exehist.cfg
./home/root/.e/e/config/illume/e.cfg
./home/root/.e/e/config/profile.cfg
./home/root/.e/e/fileman
./home/root/.e/e/fileman/custom.cfg
./home/root/.e/e/appshadow
./home/root/.e/e/appshadow/0000.desktop
./home/root/.e/e/appshadow/0001.desktop
./home/root/.e/e/appshadow/0002.desktop
./home/root/.e/e/appshadow/0003.desktop
./home/root/.e/e/appshadow/0004.desktop
./home/root/.e/e/appshadow/0005.desktop
./home/root/.e/e/appshadow/0006.desktop
./home/root/.e/e/appshadow/0007.desktop
./home/root/.e/e/appshadow/0008.desktop
./home/root/.e/e/appshadow/0009.desktop
./home/root/.e/e/appshadow/000a.desktop
./home/root/.e/e/appshadow/000b.desktop
./home/root/.e/e/appshadow/000c.desktop
./home/root/.ash_history
./home/root/.python-history
./home/root/.Xauthority
./home/root/.tangogps
./home/root/.tangogps/poi.db
./etc/asound.state
./etc/frameworkd.conf
./etc/timestamp
./etc/freesmartphone/persist
./etc/freesmartphone/persist/ogpsd.pickle
./usr/lib/opkg/lock
./dev
./.python-history

I also tried removing the ogpsd.pickle file to see if there was any issues with the ALM/EPH data in there, but the results were the same.

comment:4 Changed 6 years ago by jluebbe

  • Status changed from new to assigned

It seems that your ublox chip crashes ("Exception 0x80000040 was trapped !"). Then it restarts and defaults back to NMEA mode.

$GPTXT,01,01,02,u-blox ag - www.u-blox.com*50
$GPTXT,01,01,02,ANTARIS ATR062x HW 80040001*26
$GPTXT,01,01,02,ROM CORE       5.00    Jan 09 2006 12:00:00*76
$GPTXT,01,01,02,LIC 1EBF-BD07-E83D-6BE1-0F7A*50
$GPTXT,01,01,00,Exception 0x80000040 was trapped !*7E
$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30
$GPGGA,,,,,,0,00,99.99,,,,,,*48
$GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
$GPGSV,1,1,00*79
$GPGLL,,,,,,V,N*64
$GPZDA,,,,,00,00*48
$GPTXT,01,01,02,ANTSUPERV=AC SD OD PDoS *0A
$GPTXT,01,01,02,ANTSTATUS=SHORT*6D
$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30
$GPGGA,,,,,,0,00,99.99,,,,,,*48
$GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
$GPGSV,1,1,01,02,,,31*78
$GPGLL,,,,,,V,N*64
$GPZDA,,,,,00,00*48
$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30
$GPGGA,,,,,,0,00,99.99,,,,,,*48

comment:5 Changed 6 years ago by Sascha

Exception 80000040 is a floating point NaN trap...

comment:6 Changed 6 years ago by carllobo

I deleted the ogpsd.pickle file, restarted fso-gpsd and frameworkd and the errors somehow stopped. I tried the assist-online python script in the openmoko wiki as well and it worked as it usually does. I also got a fix in a decent bit of time. After I exited tangogps and GPS was switched off I searched for discarded

root@neo ~ $ grep iscarde /var/log/frameworkd.log
2008.12.13 11:58:06 ogpsd DEBUG Discarded data not UBX '\x00$GPTXT,01,01,02,u-blox ag - www.u-blox.com*50\r\n$GPTXT,01,01,02,ANTARIS ATR062x HW 80040001*26\r\n$GPTXT,01,01,02,ROM CORE 5.00 Jan 09 2006 12:00:00*76\r\n$GPTXT,01,01,02,LIC 1EBF-BD07-E83D-6BE1-0F7A*50\r\n$GPRMCVN*53\r\n$GPVTG,N*30\r\n$GPGGA0,00,99.99*48\r\n$GPGSA,A,1,99.99,99.99,99.99*30\r\n$GPGSV,1,1,00*79\r\n$GPGLLV,N*64\r\n$GPZDA,00,00*48\r'
2008.12.13 11:58:06 ogpsd DEBUG Discarded data not UBX '\n'

and a grep for exception and the error number didn't appear.

I'm running the updated SHR on a freerunner.

comment:7 Changed 6 years ago by daniel

I'm not sure why this happens, but ogpsd should check for the banner messages ($GPTXT,01,01,02,u-blox ag - www.u-blox.com*50) and if it sees them it should reinitialize the GPS. It would still be good to find the root cause for this.

comment:8 Changed 6 years ago by kelvan

Is their a work-around for this issue?
Removing ogpsd.pickle doesn't work for me (fso-gpsd recreate the file when it start's)
Will MS 5 have a fix for this?

(I used my freerunner to map osm, but without GPS ... :()

http://www.logic.at/people/kelvan/frameworkd.log

comment:9 Changed 6 years ago by kelvan

This seems to work:

  1. /etc/init.d/fso-gpsd stop
  2. echo 1 > /sys/class/i2c-adapter/i2c-0/0-0073/neo1973-pm-gps.0/pwron
  3. tail -f /dev/ttySAC1 (wait for fix)
  4. /etc/init.d/fso-gpsd start (kill tail before ;))
  5. start tangogps
  6. be happy :D

comment:10 Changed 6 years ago by daniel

  • Milestone set to milestone5.5

comment:11 Changed 6 years ago by jluebbe

  • Resolution set to fixed
  • Status changed from assigned to closed

I've fixed a bug with uploading the initial position, this fixed the gps chip crash i could reproduce. If the crash still happens, please reopen with a ogpsd debug log and ogpsd.pickle file.

comment:12 Changed 6 years ago by jeroen.wouters

I am still having this issue (milestone 5), I can get a fix in openmoko-agpsui, but not in zhone or tangogps.
Would you care to elaborate on how you fixed this, i.e. how to upload the initial position?

comment:13 Changed 6 years ago by jluebbe

Are you running the current frameworkd version? If not, please update.

comment:15 Changed 6 years ago by jeroen.wouters

Thanks, that patch did indeed fix it.

Note: See TracTickets for help on using tickets.