Warning: Can't synchronize with repository "(default)" (No changeset 96d22ec3fa3ef6de3ea8dc0d7d398adc9aa071cf in the repository). Look in the Trac log for more information.

Ticket #223 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

SetAntennaPower needs to be called twice

Reported by: chrysn@… Owned by: mickey
Priority: minor Milestone:
Component: framework/ogsmd Version:
Keywords: Cc:

Description

when starting the GSM resource, two calls SetAntennaPower?(True) need to be done on the org.freesmartphone.GSM.Device interface, one before and one after pin entry.

if the first call is not done, the second (after successful pin submission) raises "org.freesmartphone.GSM.SIM.AuthFailed?: SIM PIN required".

the attached program demonstrates the problem. comment out the try/except/else block and the program will die with said exception.

this was tested on a gta02 running milestone4 with an austrian "a1" sim card (in case this matters).

if the behavior is by design, it should be documented.

Attachments

ghone-minimal (833 bytes) - added by chrysn@… 5 years ago.
example program turning on the antenna. set PIN appropriately. comment out try/except/else to see exception.

Change History

Changed 5 years ago by chrysn@…

example program turning on the antenna. set PIN appropriately. comment out try/except/else to see exception.

comment:1 Changed 5 years ago by mickey

  • Status changed from new to closed
  • Resolution set to fixed

This is by design. It's now documented in the reference docs, thanks!

Note: See TracTickets for help on using tickets.