Warning: Can't synchronize with repository "(default)" (No changeset 96d22ec3fa3ef6de3ea8dc0d7d398adc9aa071cf in the repository). Look in the Trac log for more information.

Ticket #147 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

frameworkd is broken in testing

Reported by: jim@… Owned by: rwhitby
Priority: major Milestone:
Component: packaging/distribution Version:
Keywords: frameworkd libpyglib Cc:

Description

Installed testing image http://downloads.freesmartphone.org/fso-testing/images/openmoko-fso-image-glibc-ipk--20080918-om-gta02.rootfs.jffs2 and kernel http://downloads.freesmartphone.org/fso-testing/images/uImage-2.6.24+r7+gitrca19d156400f817960efe0d14680324b2ea34171-r7-om-gta02.bin

Zhone UI says "connecting w/dbus..." forever

/tmp/zhone.log keeps repeating:

2008-09-18 22:17:51,945 DEBUG dbus_objectInit...
2008-09-18 22:17:51,965 WARNING could not create proxy for org.freesmartphone.frameworkd:/org/freesmartphone/Framework
2008-09-18 22:17:51,973 ERROR could not connect to org.freesmartphone.frameworkd -- is the framework daemon started?

Frameworkd is not running and doesn't start. Running it from the shell gives this:

root@om-gta02:~# /usr/bin/frameworkd
frameworkd INFO     Installprefix is /usr
Traceback (most recent call last):
  File "/usr/bin/frameworkd", line 19, in <module>
    from framework import controller
  File "/usr/lib/python2.5/site-packages/framework/controller.py", line 21, in <module>
    from gobject import MainLoop, idle_add
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gobject/__init__.py", line 33, in <module>
    from glib import spawn_async, idle_add, timeout_add, timeout_add_seconds, \
  File "/usr/lib/python2.5/site-packages/gtk-2.0/glib/__init__.py", line 30, in <module>
    from glib._glib import *
ImportError: libpyglib-2.0.so.0: cannot open shared object file: No such file or directory

I tried installing python-pygobject-dev because http://downloads.freesmartphone.org/fso-testing/feeds/armv4t/Packages.filelist said it provides libpyglib-2.0.so.0, but the file was still missing after the install.

Change History

comment:1 Changed 6 years ago by anonymous

  • Status changed from new to closed
  • Resolution set to invalid

Please downgrade to python-pygobject 2.14.2.

In general, please don't update your whole distro just because you can. Updating individual packages is better to keep things working.

comment:2 Changed 6 years ago by jim@…

This problem was not caused by opkg upgrade. As I noted above, I flashed yesterday's image. Since you resolved the bug, I tried flashing today's image which still fails in the same way. Your choice as to whether you reopen the bug, but the fso-testing image is still broken, and the version of python-pygobject in the repository is still wrong.

comment:3 Changed 6 years ago by rod@…

  • Status changed from closed to reopened
  • Resolution invalid deleted

root@om-gta02:~# opkg remove -force-depends python-pygobject Removing package python-pygobject from root... root@om-gta02:~# opkg install http://downloads.freesmartphone.org/fso-testing/feeds/armv4t/morgue/python-pygobject_2.14.2-r1_armv4t.ipk

Downloading http://downloads.freesmartphone.org/fso-testing/feeds/armv4t/morgue/python-pygobject_2.14.2-r1_armv4t.ipk Installing python-pygobject (2.14.2-r1) to root... Configuring python-pygobject

Will close ticket after fso-testing feed and images has been fixed.

comment:4 Changed 6 years ago by rwhitby

  • Owner changed from mickey to rwhitby
  • Status changed from reopened to new

comment:5 Changed 6 years ago by rwhitby

  • Status changed from new to closed
  • Resolution set to fixed

feeds and images are fixed now.

Note: See TracTickets for help on using tickets.